Pocket

PHP5.5 環境では、Zabbix 2.0.5 画面にて「mysql_connect()」の赤文字警告が表示される件

  • add this entry to hatena bookmark

Zabbix2.0.5 マネージャ(フロントGUI画面)が動いているPHP環境をバージョン5.4から5.5にバージョンアップした際に、以下の赤文字警告が表示されるようになりました。

mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead [include/db.inc.php:77]

php55_zabbix_mysql_connect_error

調べてみると、ZBX-6020 “mysql” extension is deprecated for PHP 5.5, zabbix frontend should be ready for this として、Zabbix Support でも認識されていました。

Resolution は「Fixed」となっているのですが、Fix Version/s は「2.0.8rc1, 2.2.0」となっています。現状の Zabbix 2.0 安定版は「2.0.7」ですので(2013年7月31日リリース)、まだ安定版では未対応という事になります。

折角バージョンアップしたPHP環境ですが、5.5 から 5.4 の最新版にダウングレードしました・・・。残念ですが、PHP5.5へのバージョンアップはZabbixが次にバージョンアップした時になりそうです。

Pocket

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です


*

チェックサイト RSS Feed読者登録はいかがでしょうか?RSS配信中です。